設為首頁加入收藏

微信關注
官方微信號:qingfeng7777777a
加關注獲取每日精選資訊
股票入門歡迎您加入
廣告服務聯系我們網站地圖

暴漲前選股指標公式,通達信游資主圖指標公式

2019-06-25 21:19:01 技術分析知識庫

暴漲前選股指標公式 M:=7;
A:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N);
A1:=HIGH-REF(HIGH,1);
A2:=REF(LOW,1)-LOW;
DMP:=SUM(IF(A1>0 AND A1>A2,A1,0),N);
DMM:=SUM(IF(A2>0 AND A2>A1,A2,0),N);
PDI:=DMP*100/A;
MDI:=DMM*100/A;
ADX:=MA((ABS(MDI-PDI))/(MDI+PDI)*100,M);
ADXR:=(ADX+REF(ADX,M))/2;
暴漲前:IF(ADX>90 AND PDI=0,3,0),LINETHICK2,COLORFFFFFF;

通達信游資主圖指標公式

在均線系統上加入了許多操盤信號,有盤面分析,有買賣點提示,有變盤窗口提示,有頂底提示,有短線波段等提示。

指標源碼:

MA5:MA(C,5);

MA6:=MA(C,6);

MA10:MA(C,10);

MA20:MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);

MA30:MA(C,30);

MA60:MA(C,60);

MA120:MA(C,120);

乖離2:=(MA20-MA30)/MA30*100;

VAR1:=IF(BETWEEN(乖離2,-2,5),2,0);

MAX1:=MAX(MA20,MA30);

MAX2:=MAX(MAX1,MA60);

MIN11:=MIN(MA20,MA30);

MIN2:=MIN(MIN11,MA60);

K1:=(MAX2/MIN2-1)*100;{粘合度符合條件}

VAR2:=IF(K1<=8,1,0);

上火車軌:=MA20>MA30 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1) AND MA20-MA30>REF((MA20-MA30),1) ;

STICKLINE(上火車軌,MA20,MA30,0,0),COLORRED;

神槍手:=DRAWTEXT(FILTER(上火車軌 AND "MACD.DIF"<0.15 AND "MACD.DIF">REF("MACD.DIF",1) AND MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND

( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20)) ),5),L*0.98,\'←神槍手\');

神槍手選股:=FILTER(上火車軌 AND "MACD.DIF"<0.15 AND "MACD.DIF">REF("MACD.DIF",1) AND MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND

( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20)) ),5);{44.40%15240}

短線暴張:DRAWTEXT(FILTER( (VAR1 OR VAR2) AND MA10>REF(MA10,1) AND COUNT(MA30>REF(MA30,1),3)=3 AND MA30>MA60 AND COUNT(CROSS(MA5,MA30),3) AND J1>MJ1 AND MA(V,5)>MA(V,60)

AND MA(V,60)>REF(MA(V,60),1),5),MA60*0.99,\'短線暴張\'),COLORRED;

DRAWTEXT(CROSS("KDJ.K"(5,2,3),"KDJ.D"(5,2,3)) AND "KDJ.D"(5,2,3)<30 AND J1>MJ1 AND MA60>REF(MA60,1) AND COUNT(J1<1,3)>=1 ,L*0.995,\'←買入\'),COLORYELLOW;

DRAWTEXT(CROSS("KDJ.D"(5,2,3),"KDJ.K"(5,2,3)) AND "KDJ.D"(5,2,3)>65 AND J1<MJ1 AND COUNT(J1>1,3)>=1,H*1.005,\'←賣出\'),COLORGREEN;

DRAWTEXT(CROSS("KDJ.D"(18,9,6),"KDJ.K"(18,9,6)) AND "KDJ.D"(18,9,6)>60 AND "KDJ.J"(45,15,15)>90,H*1.03,\'←頂\'),COLORRED;

DRAWTEXT(CROSS(MA5,MA6) AND "KDJ.K"(5,3,3)>=50 AND "KDJ.J"(5,3,3)<31 ,L*0.92,\'←再買\'),COLORMAGENTA;

XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));

XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);

XL3:=CROSS(XL2,(0 - 20));

DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.4),\'●買點\');

DRAWTEXT((XL3 > 0),(LOW - 0.2),\'●絕對底部\');

X6:=REF(CLOSE,1);

X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);

X8:=CROSS(79,X7);

X9:=FILTER(X8,4);

DRAWTEXT(X9,(HIGH * 1.02),\'●出貨\'),COLOR9000F5;

STICKLINE(C>1.098*REF(C,1),C,O,0,0),COLORYELLOW;

AAA:=CONST(HHV(H,90));

R1:=MA(CLOSE,1);

R2:=MA(CLOSE,3);

R3:=(MA(R2,1)*1);

R4:=(MA(R2,3)*1);

DRAWTEXT(CROSS(R3,R4),(LOW-0.1),\'進\'),COLORYELLOW;

LC:=REF(CLOSE,1);

RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);

FF:=EMA(CLOSE,3);

MA15:=EMA(CLOSE,21);

DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),\'出\'),COLORGREEN;

VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

VAR12:=(HIGH+LOW+CLOSE)/3;

VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));

VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));

VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);

VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);

VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

VAR18:=100-ABS(VAR17);

VAR19:=IF(VAR18<90,VAR18,100);

VAR1A:=IF(VARE>0,VARE,0);

VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;

VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;

DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,HIGH*1.02,\'大筆出貨\'),LINETHICK1,COLORFFCC66;

AA1:=AMOUNT/V;

BB1:=L<AA1*0.9;

CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;

DD1:=L<MA(C,5)*0.921;

EE1:=V<MA(V,5)*1.5;

老鼠倉:=BB1 AND CC1 AND DD1 AND EE1,LINETHICK0;

DRAWTEXT(老鼠倉,(LOW* 0.99),\'老鼠倉\'),COLOR40CCFF;

A74:=MA(CLOSE,20);

A75:=(CLOSE > MA(CLOSE,5));

A76:=(MA(CLOSE,5) > MA(CLOSE,10));

A77:=(CLOSE > MA(CLOSE,10));

A78:=(MA(CLOSE,5) > MA(CLOSE,20));

A79:=(CLOSE > MA(CLOSE,20));

A710:=REF(A74,1);

A711:=(A74 > A710);

AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10)))

+ IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10)));

DSLX:=(CLOSE / INDEXC);

DSLX1:=MA(DSLX,5);

DSLX2:=MA(DSLX,10);

V1:=MA(VOL,5);

V2:=MA(VOL,10);

T1:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));

T2:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));

T3:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)),1,0));

T4:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)),1,0));

T5:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));

T6:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));

T7:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));

T8:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));

T9:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));

T10:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));

T11:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));

T12:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));

T13:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));

T14:=CONST(IF( C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));

T15:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));

T16:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));

T17:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));

T18:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));

T19:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 < V2)),1,0));

T20:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 >= V2)),1,0));

T21:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 < V2)),1,0));

T22:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)),1,0));

T23:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)),1,0));

T24:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)),1,0));

T25:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)),1,0));

DRAWTEXT(T1=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'量能理想,明顯走強,中線參與,倉位在2/3左右\'),COLORFF00FF ;

DRAWTEXT(T2=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'走勢趨強,還顯不足,短線進場,倉位在1/2左右\'),COLORFF00FF ;

DRAWTEXT(T3=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'量價良好,沒有明顯走強,短線進場,倉位1/2左右\'),COLORFF00FF ;

DRAWTEXT(T4=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'形態尚可,量能不足,未完全走強,短線參與,倉位1/3左右\'),COLORFF00FF ;

DRAWTEXT(T5=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'形態變壞,重倉者減持大半,清倉者觀望\'),COLORFF00FF ;

DRAWTEXT(T6=1 AND CURRBARSCOUNT=70,AAA*0.98

,\'隨大盤一起下跌,明顯縮量走勢,考慮到風險,減持或清倉\'),COLORFF00FF ;

DRAWTEXT(T7=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'該股放量下跌,走勢明顯偏弱,離場觀望\'),COLORFF00FF ;

DRAWTEXT(T8=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'該股縮量下跌,走勢偏弱,離場觀望。\'),COLORFF00FF ;

DRAWTEXT(T9=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'該股形態良好,強勢明顯,量能充足,可以繼續持有\'),COLORFF00FF ;

DRAWTEXT(T10=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'上行趨勢不變,強勢依然,量能開始轉弱,注意風險\'),COLORFF00FF ;

DRAWTEXT(T11=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'該股仍然具備上漲潛力,但股性偏弱,可考慮減倉\'),COLORFF00FF ;

DRAWTEXT(T12=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'該股走勢趨弱,量能不足,減持大部分籌碼\'),COLORFF00FF ;

DRAWTEXT(T13=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'該股形態不佳,注意成交量的變化,目前不適合參與\'),COLORFF00FF ;

DRAWTEXT(T14=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'趨勢不明,股價偏弱,注意量能變化,目前不宜參與\'),COLORFF00FF ;

DRAWTEXT(T15=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'有走強跡象,但量能不足,趨勢不明,不適合操作\'),COLORFF00FF ;

DRAWTEXT(T16=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'該股走勢太弱,沒有參與價值。\'),COLORFF00FF ;

DRAWTEXT(T17=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'大盤理想,有明顯走強跡象,中線參與,倉位在2/3左右\'),COLORFF00FF ;

DRAWTEXT(T18=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'如前期經過一輪下跌,最佳買點,前期有過一段漲幅需謹慎\'),COLORFF00FF ;

DRAWTEXT(T19=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'考慮短線進場,倉位在1/2左右,一旦量能放大,加倉買入\'),COLORFF00FF ;

DRAWTEXT(T20=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'大盤形態走壞,重倉者可以減去大部分倉位。\'),COLORFF0000 ;

DRAWTEXT(T21=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'大盤縮量調整,注意風險,短線清倉觀望。\'),COLORFF0000 ;

DRAWTEXT(T22=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'大盤走勢良好,量能理想,可以繼續持有強勢股。\'),COLORFF0000 ;

DRAWTEXT(T23=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'大盤形態良好,但量能稍顯不足,隨時準備減倉。\'),COLORFF0000 ;

DRAWTEXT(T24=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'大盤趨勢不明,注意成交量變化,目前不適宜進場。\'),COLORFF0000 ;

DRAWTEXT(T25=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)

,\'大盤趨勢向下,量能萎縮,不適合進場。\'),COLORFF0000 ;

AA:=BARSCOUNT(C);

AH:=HHV(H,200);

AL:=LLV(L,200);

A0:=(AH-AL)/40;

B1:=L-A0;

STICKLINE((AA+0)/34=FLOOR((AA+0)/34),B1,B1-1.5*A0,2,0),COLORF00FF0;

DRAWTEXT((AA+0)/34=FLOOR((AA+0)/34),B1-1*A0,\'時間窗,變盤\'),COLORF00FF0;

VAR2S:=(2*CLOSE+HIGH+LOW)/4;

VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);

VAR4S:=LLV(LOW,5); VAR5S:=HHV(HIGH,4);

散戶:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;

莊家:=EMA(0.667*REF(散戶,1)+0.333*散戶,2)*VAR3S;

DRAWTEXT(CROSS(散戶,莊家) AND 散戶<30,L-0.05,\'←吸\'),COLORRED;

BBB1:=MA(C,1);

B2:=SMA(SMA(SMA(BBB1,2,1),2,1),2,1),COLORRED;

SMA2:=MA(B2,2);

VARB1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));

VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));

買:DRAWTEXT(CROSS(VARB1,VAR3) AND B2>SMA2,(LOW * 0.97),\'←⊙買\'),COLORRED;

[!--temp.sitename--]聲明:資訊來源于互聯網,屬作者個人觀點,僅供投資者參考,并不構成投資建議。投資者據此操作,風險自擔。

p3开机号最近10期